Последние записи

Mikrotik DHCP-server: оповещение о новых хостах и привязка к статике

Что делает скрипт: при выдаче адреса в аренду, если это адрес новый (динамический), то он будет преобразован в статическую аренду и на адрес admin@example.com будет отправлено письмо. В контексте исполнения скрипта при выдаче аренды доступны следующие переменные:
$leaseBound - 1 или 0, успешно ли выдана аренда
$leaseServerName - имя dhcp-server'а который выдал аренду
$leaseActMAC - MAC устройства которому выдан адрес
$leaseActIP - сам выданный адрес

/ip dhcp-server lease
:local isdynamic [get [find mac-address=$leaseActMAC] dynamic];

:if ($leaseBound = 1 and $isdynamic) do={
    :local hostname [get [find where active-mac-address=$leaseActMAC] host-name];
    add mac-address=$leaseActMAC address=$leaseActIP server=$leaseServerName comment=$hostname
    /tool e-mail
    send server="mail.example.com" from="mikrotik@example.com" to="admin@example.com" password="strongpass" start-tls=yes subject="New static lease: $hostname - $leaseActIP" user="mikrotik@example.com"
}

Mikrotik official Wiki: DHCP-Server

2019/02/26 10:49 · admin

Настройка wireguard на Debian 9

Почему wireguard? Мне очень понравилась концепция, быстрая и простая настройка, представляет собой обычный сетевой интерфейс в системе, использует современные алгоритмы шифрования.

На самом деле установка и настройка простая и доступно описана в официальной документации, но я по неопытности столкнулся с неочевидными моментами и решил себе это все задокументировать.

В связи с блокировками РКН мне нужно было завернуть бота Telegram в VPN, использовать проксю в данном случае было нельзя, решил завернуть всю сеть телеги в туннель. Входные данные следующие:
1) Виртуальная машина за NATом с ботом телеги на борту, назовем ее BOT
2) Зарубежная VPSка с белым внешним IP x.x.x.x, назовем ее VPS

Читать дальше...

2018/09/23 13:33 · admin

Меняем максимальное кол-во RAM для базы WSUS

Все это делается в контексте «Windows Server 2012 R2»/«WSUS 4». Но думаю для «WSUS 3» особых отличий не будет.

Первым делом качаем Native Client и sqlcmd по ссылке: https://www.microsoft.com/ru-RU/download/details.aspx?id=35580

Читать дальше...

2017/05/17 10:39 · admin

DynamicDNS namecheap.com на Mikrotik

Простенький скрипт, уже давно пользуюсь. Обновляет с помощью http запроса.

Для начала заходим в настройки DNS записей домена и включаем поддержку DynamicDNS. При включении нам выдадут пароль для обновления записей только этого домена.

Читать дальше...

2017/01/11 17:06 · admin

Длинные очереди в Zabbix

Если наблюдаются длинные очереди в zabbix, «Administration → Queues», но данные собираются исправно и при этом нет никаких проблем с производительностью железа и стабильности сети, то причины остается две:

  • Рассинхрон времени между клиентом и сервером заббикса;
  • Не совпадающие версии серверной и клиентской части.
2017/01/11 17:05 · admin

SPF является одним из инструментов для борьбы со спамом и поддельными письмами. Он позволяет получателю проверить - имеет ли право приславший почту хост отправлять почту от имени данного домена.
Выражение SPF хранится в обычной TXT записи доменной зоны и имеет следующий вид:

"ver=spf1 <механизмы>"

Читать дальше...

2017/01/11 17:04 · admin

Настройка Tor прокси под Windows

Скачиваем Expert Bundle* Скачиваем с официального сайта и распаковываем скачанный архив в папку, где хотим, что бы располагался tor, например C:\tor.

В каталоге C:\tor\Data\Tor создаем файл «torrc» со следующим содержимым.

torrc
DataDirectory c:\tor\Data\Tor
GeoIPFile c:\tor\Data\Tor\geoip
GeoIPv6File c:\tor\Data\Tor\geoip6

#Проводить меньше операций с диском
AvoidDiskWrites 1

#Локальный интерфейс и порт на котором будет слушать запросы SOCKS прокси
#Можно указать несколько вхождений для разных интерфейсов и портов
SocksPort 192.168.10.10:9150

Создаем разрешающее правило в брандмауэре.

cmd> netsh advfirewall firewall add rule name="Tor Proxy" dir=in action=allow localport=9150 protocol=tcp

Дальше можно просто создать ярлык со следующей строкой запуска:
c:\tor\Tor\tor.exe -f c:\tor\Data\Tor\torrc
И запускать через него, при этом консольное окошко будет висеть в окружении пользователя.

Читать дальше...

2017/01/11 17:03 · admin

Отключение IPv6 в Windows

cmd> reg add hklm\system\currentcontrolset\services\tcpip6\parameters\ /v DisabledComponents /t REG_DWORD /d 0xff

И перезагрузиться.

{{ :blog:disable_ipv6.png?nolink |

Доп. сведения: Статья на TechNet

2017/01/11 17:02 · admin

Установка и настройка прокси-сервера Zabbix

Допустим у нас есть машина с установленным Debian 8. Установим и настроим пассивную проксю с бд в sqlite.

Добавим пакет который сам установит репозиторий zabbix и ключ для него (проверьте актуальность версии тут http://repo.zabbix.com/zabbix/):

wget http://repo.zabbix.com/zabbix/3.0/debian/pool/main/z/zabbix-release/zabbix-release_3.0-1+jessie_all.deb
dpkg -i zabbix-release_3.0-1+jessie_all.deb

Читать дальше...

2017/01/11 17:02 · admin

Заметка по queues bursting в mikrotik

Калькулятор burst'а: https://ip-pro.eu/en/tools/mikrotik_burst_calculator

Формула по которой считается реальное время работы burst'a:
burst-threshold * burst-time / burst-limit

Официальная wiki

2017/01/11 17:01 · admin